Radicore Forum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » RADICORE » RADICORE Installation Issues » Radicore v2.0 on a single database (Radicore v2.0 on a single database)
Radicore v2.0 on a single database [message #5973] Sat, 15 October 2016 14:39 Go to next message
Laevus is currently offline  Laevus
Messages: 3
Registered: October 2016
Junior Member
I am trying to get Radicore v2.0 to work on a single database.

I have created a new mysql database named BLOG and a new user BLOGAdmin with full access to it.
I have also run the requisite mysql schema and data files against BLOG as per the installation guide.

I have the following config.inc as per FAQ150 and FAQ92:

<<
...
if (preg_match('/^(127.0.0.1|localhost|desktop|laptop)$/i', $_SERVER['SERVER_NAME'])) {
global $servers;
// server 0
$servers[0]['dbhost'] = 'localhost';
$servers[0]['dbengine'] = 'mysql';
$servers[0]['dbusername'] = 'BLOGAdmin';
$servers[0]['dbuserpass'] = '<real password>';
$servers[0]['dbnames'] = 'audit,dict,menu,workflow,product,survey';
$servers[0]['switch_dbnames'] = array('audit' => 'blog',
'dict' => 'blog',
'menu' => 'blog',
'workflow' => 'blog',
'product' => 'blog',
'survey' => 'blog');
// server 1
$servers[1]['dbhost'] = 'localhost';
$servers[1]['dbengine'] = 'mysql';
$servers[1]['dbusername'] = 'BLOGAdmin';
$servers[1]['dbuserpass'] = '<real password>';
$servers[1]['dbnames'] = '*';
...
>>

When I navigate my browser to http://localhost/radicore/index.html and click the Logon link, I get the following error:

<<
This application has encountered an unrecoverable error

The following has been reported to the administrator:

2016-10-15 20:30:27

Fatal Error: MySQL: Unknown database 'audit' (# 1049)

Error in line 89 of file 'C:\xampp\htdocs\radicore\includes\dml.mysqli.class.inc'.

Host Info: localhost via TCP/IP
Server Version: 5.6.20
Client Version: mysqlnd 5.0.11-dev - 20120503 - $Id: f373ea5dd5538761406a8022a4b8a374418b240e $, Character sets - client: utf8, - connection: utf8, - database: utf8, - server: utf8

PHP_SELF: /radicore/menu/logon.php

CURRENT DIRECTORY: C:\xampp\htdocs\radicore\menu

SERVER_ADDR: ::1

SERVER_NAME: localhost

HTTP_HOST: localhost

REMOTE_ADDR: ::1

REQUEST_URI: /radicore/menu/logon.php?csxslt=off
>>

Any suggestions would be appreciated.

Thanks in advance.
Re: Radicore v2.0 on a single database [message #5974 is a reply to message #5973] Sat, 15 October 2016 15:25 Go to previous messageGo to next message
AJM is currently offline  AJM
Messages: 2045
Registered: April 2006
Location: Surrey, UK
Senior Member
My apologies. This needs just a quick one-line edit. In file std.table.class.inc go to method _getDBMSengine() and change the 4th line from
$this->dbname_server = $dbprefix.$dbname;

to
$this->dbname_server = $dbprefix.$dbname2;


Re: Radicore v2.0 on a single database [message #5975 is a reply to message #5974] Sat, 15 October 2016 17:51 Go to previous message
Laevus is currently offline  Laevus
Messages: 3
Registered: October 2016
Junior Member
That works.

Thank you very much.
Previous Topic: Radicore v2.00.0
Next Topic: radicore-tutorial-001.pdf relationships does not work
Goto Forum:
  


Current Time: Sat Apr 29 19:12:35 EDT 2017

Total time taken to generate the page: 0.02215 seconds